dinsdag 26 augustus 2008

SharePoint Web Cluster

Het project zit niet echt mee. Blijkt de config dbase van SharePoint corrupt te zijn. Hierdoor is het onmogelijk om een nieuwe server toe te voegen aan de farm. Wat de verplaatsing van SharePoint meteen complex maakt. Namelijk zou je bij het toevoegen van een extra server in de farm de zaken kunnen repliceren en zodoende makkelijk weer de 'oude' sharepoint server kunnen ontkoppelen. Waardoor je sharepoint dus makkelijk 'fysiek' kunt verplaatsen. Helaas door de defecte config db is dit niet meer mogelijk. Waardoor al je settings en links meteen verdwenen zijn bij het opbouwen van een nieuwe farm. Voor de klant betekent dat ook alle 'hand-made' links opnieuw aangemaakt moeten worden binnen de diverse sites. Gelukkig is SharePoint wel zodanig door Microsoft gemaakt dat het wat betreft de security goed geregeld is. Deze permissions zijn namelijk geregeld in de content dbase. Dus het opnieuw aanmaken van je web applications en het vervolgens koppelen van de juiste content db, voila! Permissions are restored. Microsoft wordt gewoon steeds beter. Uiteraard moet je de application pools bij het aanmaken van de web applications ook opnieuw laten definiĆ«ren. Gelukkig draait de Back-end van SharePoint op het SQL Cluster, waardoor het maken van Backups van de dbases een formaliteit is. Daarnaast verhuizen we de back-end niet, enkel dus de WFE. (Web Front End). Na het opnieuw opzetten van de web applications en web parts, was sharepoint na een aantal uur weer in productie. Dus ruim voor de dead-line die was afgesproken, wanneer iedereen weer gebruik kon maken van sharepoint. Groot voordeel is nu ook dat bij het opzetten van het web cluster, enkel een node toevoeg aan de farm. Hiermee wordt alles gerepliceerd en voila! SharePoint geĆÆmplementeerd in een load balance. Als je dbases maar intact zijn en niet corrupt dan is sharepoint 'just another day at the office'



1 opmerking:

Mark Beij zei

Ik vind de afbeelding die je onder je artikel plaats niet erg relevant, maar dat ter zijde.
Heb je in de nieuwe omgeving je WFE's geclusterd, of hangt er een load balancer boven?
Ik ben aan het kijken naar mogelijkheden om de WFE die ook de indexing voor zijn rekening neemt te clusteren.
Ervaring mee?

Mark